summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTony Lambiris2018-05-08 02:17:59 -0400
committerTony Lambiris2018-05-08 02:17:59 -0400
commit50c9c318e0e979bf4a8153eaa106b21220f5c542 (patch)
tree3350dccc9e7632016f8f55f514fb1e90137ddec2 /PKGBUILD
parent937252fae06a487f99966656983b4ef58f150343 (diff)
downloadaur-50c9c318e0e979bf4a8153eaa106b21220f5c542.tar.gz
Version bump, add gcc 8 patch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b09e97d79aa8..d7ce8dae4a16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Tony <tony@criticalstack.com>
pkgname=rocksdb-static
-pkgver=5.12.2
+pkgver=5.12.4
pkgrel=1
pkgdesc='Embedded key-value store for fast storage (static library)'
arch=(i686 x86_64)
@@ -9,8 +9,10 @@ url='http://rocksdb.org'
license=('Apache')
depends=(gperftools zlib bzip2 lz4 snappy gcc-libs)
checkdepends=(python2)
-source=(https://github.com/facebook/rocksdb/archive/v$pkgver.zip)
-sha256sums=('a855b6dec88d1596cc78e03ab21027cf664d385e25fa7693a5813c84cec89a41')
+source=(https://github.com/facebook/rocksdb/archive/v$pkgver.zip
+ fix-gcc-8-warnings.patch)
+sha256sums=('d54b1870ed343f80f96326b7de7fd798e8ddd11f05ef413c0e3357219f08ac67'
+ '2c5d96fbf1638d899da84b4a80ad3c6060b774ed80148f443ae40672d31df9d3')
prepare() {
cd rocksdb-$pkgver
@@ -18,6 +20,7 @@ prepare() {
if [ "$CARCH" == "armv6h" ]; then
sed -e 's/-momit-leaf-frame-pointer//' -i Makefile
fi
+ patch -Np1 -i ../fix-gcc-8-warnings.patch
}
build() {