summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2020-03-17 21:28:09 -0400
committeracxz2020-03-17 21:28:09 -0400
commit491cf873991080c2a4538fc5cc4efa181d458c22 (patch)
treed54c8c600b2ae2f2e1f9a5d652d625e861ca87b0 /PKGBUILD
parentb42c274c19620ec3e2b9731f2bbf668d2625f9d0 (diff)
downloadaur-491cf873991080c2a4538fc5cc4efa181d458c22.tar.gz
updpkg: 3.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 23 insertions, 22 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9e07ca40ad95..9fb2c6cdc909 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,30 @@
-# Maintainer: Lucas Magalhães <whoisroot@national.shitposting.agency>
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+# Contributor: Lucas Magalhães <whoisroot@national.shitposting.agency>
pkgname=rocm-clang-ocl
-pkgver=0.4.0
-_buildrel=7ce124f
+pkgver=3.1.0
pkgrel=1
-_debfile=rocm-clang-ocl_${pkgver}-${_buildrel}_amd64.deb
pkgdesc="OpenCL compilation with clang compiler."
arch=('x86_64')
-url="https://github.com/RadeonOpenCompute/ROCm"
-license=('EULA')
-groups=()
-depends=()
-makedepends=()
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
-replaces=()
-backup=()
-options=()
-source=("http://repo.radeon.com/rocm/apt/debian/pool/main/r/rocm-clang-ocl/${_debfile}")
-sha256sums=('SKIP')
+url="https://github.com/RadeonOpenCompute/clang-ocl"
+license=('unknown')
+makedepends=('cmake' 'hcc')
+source=("${pkgname}-${pkgver}::http://github.com/RadeonOpenCompute/clang-ocl/archive/roc-${pkgver}.tar.gz")
+sha256sums=('af93e626564cee2b3f6f5c2da0b5b95a9894f7357d895b259a706d38a57f1ef6')
+_pkgname=clang-ocl
+
+build() {
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
+
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DOPENCL_ROOT=/opt/rocm/hcc \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm \
+ "$srcdir/$_pkgname-roc-$pkgver"
+ make
+}
package() {
- cd "$srcdir"
- tar xf data.tar.gz
-
- mkdir -p ${pkgdir}/opt/rocm/bin
-
- cp -ax opt/rocm/bin/* ${pkgdir}/opt/rocm/bin
+ cd "$srcdir/build"
+
+ make DESTDIR="$pkgdir" install
}