summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLucas Magalhães2019-03-21 16:37:20 -0300
committerLucas Magalhães2019-03-21 16:37:20 -0300
commit68e09826926d23ada5d336d8772683e229062d8b (patch)
treee4ff5fe6569c0ff0e56b7cc5712ff05d5515f835 /PKGBUILD
downloadaur-68e09826926d23ada5d336d8772683e229062d8b.tar.gz
Adding rocm-clang-ocl to aur
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..206e1cec3c24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Lucas Magalhães <whoisroot@national.shitposting.agency>
+pkgname=rocm-clang-ocl
+pkgver=0.4.0
+_buildrel=7ce124f
+pkgrel=1
+_debfile=rocm-clang-ocl_${pkgver}-${_buildrel}_amd64.deb
+pkgdesc="OpenCL compilation with clang compiler."
+arch=('x86_64')
+url="https://github.com/RadeonOpenCompute/ROCm"
+license=('EULA')
+groups=()
+depends=()
+makedepends=()
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+source=("http://repo.radeon.com/rocm/apt/debian/pool/main/r/rocm-clang-ocl/${_debfile}")
+sha256sums=('948ec2045681160de795570ee476049d53565821e0ffe245ac2e52e0d21a5b6a')
+
+package() {
+ cd "$srcdir"
+ tar xf data.tar.gz
+
+ mkdir -p ${pkgdir}/opt/rocm/bin
+
+ cp -ax opt/rocm/bin/* ${pkgdir}/opt/rocm/bin
+}