summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorRanieri Althoff2020-02-04 04:55:47 -0300
committerRanieri Althoff2020-02-04 04:55:47 -0300
commitbcf0f75ee3d9a9dbf3bbdb9ea5b34c9eb9916fa8 (patch)
tree16ca2bf2029ca7cbb9d6759aa6547a266e486df6 /PKGBUILD
parent3595582a0882d75e7153c12e8464499bfd5e2e27 (diff)
downloadaur-bcf0f75ee3d9a9dbf3bbdb9ea5b34c9eb9916fa8.tar.gz
v3.0.0-3
- Add patch to trim useless artifacts - Cleanup scripts - Fix licenses
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD30
1 files changed, 14 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index fd3f62220388..390043cc8116 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,10 @@ _opencl_icd_loader_commit='978b4b3a29a3aebc86ce9315d5c5963e88722d03'
pkgbase=rocm-opencl-runtime
pkgname=(rocm-device-libs rocm-opencl-runtime)
-pkgdesc='Radeon Open Compute - OpenCL runtime'
pkgver=3.0.0
-pkgrel=2
+pkgrel=3
arch=('x86_64')
-url='https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime'
-license=('MIT')
-depends=("roct-thunk-interface>=${pkgver}" "rocr-runtime>=${pkgver}" 'opencl-icd-loader')
+url='https://github.com/RadeonOpenCompute'
makedepends=(mesa cmake git llvm-roc rocm-comgr)
provides=("$pkgname" 'opencl-driver')
source=(
@@ -20,12 +17,8 @@ source=(
"opencl-icd-loader::git+https://github.com/KhronosGroup/OpenCL-ICD-Loader#commit=${_opencl_icd_loader_commit}"
"rocm-opencl-runtime-2.8.0-change-AMDCompilerh.patch"
"rocm-opencl-runtime-2.8.0-change-opencl.patch"
- "rocm-opencl-runtime-2.8.0-update-README.patch"
"rocm-opencl-runtime-2.8.0-amdocl64icd.patch"
-
- # Fix build missing dependency
- # https://github.com/RadeonOpenCompute/ROCm-OpenCL-Runtime/issues/64#issuecomment-473502685
- 'fix_rocm_opencl_build_order.patch'
+ "rocm-opencl-runtime-3.0.0-change-install-location.patch"
)
sha256sums=('SKIP'
@@ -34,9 +27,8 @@ sha256sums=('SKIP'
'SKIP'
'07c437ff43942a90a658986f88d5df3d5159af3d5c506aa8d1d7281fbb74d7be'
'3af5c9c3b8b88b78a2fd574f339e88a5cd62c365d94e9289c2a2cb4afef3d435'
- '9b72ea0101c39a0e67c94d0907061fe493bd0765d884585b2e55d51fafc99fff'
'2cfd11bda9a485d6de2231c56742ad553329cab9b6dcc009dbddbcde1436f485'
- '0f735299810e9e22cd57f5b96a7628a0f399d445a1f3bacefd8b890e84ca372f')
+ '941a29f8704a2839c32bcf3cf374dde30bc8a839c1136d4faa65c60a7500cf98')
prepare() {
cd "$srcdir/rocm-opencl-runtime"
@@ -75,6 +67,7 @@ build() {
cd "$srcdir/rocm-device-libs"
mkdir -p build && cd build
cmake ${CMAKE_FLAGS[@]} \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm \
-DPREPARE_BUILTINS="$srcdir/rocm-device-libs/utils/utils/prepare-builtins/prepare-builtins" \
..
make
@@ -83,6 +76,8 @@ build() {
cd "$srcdir/rocm-opencl-runtime"
mkdir -p build && cd build
cmake ${CMAKE_FLAGS[@]} \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm \
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc \
-DCMAKE_MODULE_PATH="$srcdir/rocm-cmake/share/rocm/cmake" \
-DUSE_COMGR_LIBRARY=yes \
-Damd_comgr_DIR='/opt/rocm/lib/cmake/amd_comgr' \
@@ -91,15 +86,18 @@ build() {
}
package_rocm-device-libs() {
+ pkgdesc='Radeon Open Compute - device libs'
+ license=('unknown')
+
DESTDIR="$pkgdir/" make -C "$srcdir/rocm-device-libs/build" install
}
package_rocm-opencl-runtime() {
- DESTDIR="$pkgdir/" make -C "$srcdir/rocm-opencl-runtime/build" install
+ pkgdesc='Radeon Open Compute - OpenCL runtime'
+ depends=("roct-thunk-interface>=${pkgver}" "rocr-runtime>=${pkgver}" 'opencl-icd-loader')
+ license=('MIT')
- # OpenCL vendor file
- mkdir -p "$pkgdir/etc/OpenCL/vendors"
- echo '/opt/rocm/lib/x86_64/libamdocl64.so' > "$pkgdir/etc/OpenCL/vendors/rocm-opencl64.icd"
+ DESTDIR="$pkgdir/" make -C "$srcdir/rocm-opencl-runtime/build" install
mkdir -p "$pkgdir/etc/ld.so.conf.d"
echo '/opt/rocm/lib' > "$pkgdir/etc/ld.so.conf.d/rocm-opencl.conf"