summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTorsten Keßler2022-11-02 17:47:34 +0100
committerTorsten Keßler2022-11-02 17:47:34 +0100
commit4c5ba9ac8031a63514921e2aa0d5e374a126bc3e (patch)
treee53df91d08baaa590d34a145e3468401e4918b9b /PKGBUILD
parentc577ee62b211a59cbe6adca6e9ca39a0eb0dbdec (diff)
downloadaur-4c5ba9ac8031a63514921e2aa0d5e374a126bc3e.tar.gz
upgpkg: rocm-validation-suite 5.3.0-1
* Follow cmake template from wiki * Remove unneeded patches * Update checksum
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD41
1 files changed, 13 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 8e461c2ef8a8..2ba3103a0dd3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: codyfish <fe27 at gmx dot net>
# Contributor: sofiageo <george at sofianos dot dev>
pkgname=rocm-validation-suite
-pkgver=5.2.3
+pkgver=5.3.0
pkgrel=1
pkgdesc="Tool for detecting and troubleshooting common problems affecting AMD GPUs"
arch=('x86_64')
@@ -10,42 +10,27 @@ url="https://github.com/ROCm-Developer-Tools/ROCmValidationSuite"
license=('MIT')
depends=('pciutils' 'doxygen' 'rocblas' 'rocm-smi-lib' 'git' 'libpciaccess')
makedepends=('cmake' 'systemd')
-options=(!staticlibs strip !lto)
+options=(!lto)
_git='https://github.com/ROCm-Developer-Tools/ROCmValidationSuite'
-source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz"
- "rvs-os-type.patch::https://github.com/acxz/ROCmValidationSuite/commit/eb1a4bf5de8d8ba25f21ee13d6af1c46416e3961.patch"
- "rocblas-header.patch::https://github.com/acxz/ROCmValidationSuite/commit/3522af8597773cb5071746401280b8d813ca12cc.patch")
-sha256sums=('5dfbd41c694bf2eb4368edad8653dc60ec2927d174fc7aaa5fa416156c5f921f'
- 'SKIP'
- 'SKIP')
+source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
+sha256sums=('d6afb8a5f4eaf860fd510bcfe65e735cbf96d4b8817c758ea7aee84d4c994382')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
-prepare() {
- cd "$_dirname"
- patch -Np1 -i "$srcdir/rvs-os-type.patch"
- patch -Np1 -i "$srcdir/rocblas-header.patch"
-}
-
build() {
# -fcf-protection is not supported by HIP, see
- # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.2/page/Appendix_A.html
+ # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.3/page/Appendix_A.html
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
- cmake -B build -Wno-dev \
- -S "$_dirname" \
- -DCMAKE_INSTALL_PREFIX=/opt/rocm \
- -DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
- make -C build
+ cmake \
+ -Wno-dev \
+ -B build \
+ -S "$_dirname" \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm \
+ -DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
+ cmake --build build
}
package() {
- DESTDIR="$pkgdir" make -C build install
-
- # add links
- install -d "$pkgdir/usr/bin"
- local _fn
- for _fn in rvs; do
- ln -s "/opt/rocm/rvs/$_fn" "$pkgdir/usr/bin/$_fn"
- done
+ DESTDIR="$pkgdir" cmake --install build
install -Dm644 "$_dirname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}