summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorcodyfish2020-11-02 22:35:54 +0100
committerGitHub2020-11-02 16:35:54 -0500
commit77d46e005d2de4fdb14b51a5456de3a582a701ca (patch)
treed5cf83c998237ef1d0d8f087dd39e010fa5b2e8f /PKGBUILD
parent8a1abd2a8450d8d543aedbe1a564d0500193fc6e (diff)
downloadaur-77d46e005d2de4fdb14b51a5456de3a582a701ca.tar.gz
Patched pacman-specific solution for action command_string (#465)
Co-authored-by: Akash Patel <17132214+acxz@users.noreply.github.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a56de1042dde..b9721a335a2e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: acxz <akashpatel2008 at yahoo dot com>
pkgname=rocm-validation-suite
pkgver=3.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="Tool for detecting and troubleshooting common problems affecting AMD
GPUs"
arch=('x86_64')
@@ -10,8 +10,15 @@ license=('MIT')
depends=('pciutils' 'doxygen' 'rocblas' 'rocm-smi-lib64' 'git')
makedepends=('cmake')
options=(!staticlibs strip)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/ROCm-Developer-Tools/ROCmValidationSuite/archive/rocm-$pkgver.tar.gz")
-sha256sums=('17662028a4485b97e3ccaad5e94d20aaa2c3e9e3f741c7ebbf0f8b4cdebcc555')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/ROCm-Developer-Tools/ROCmValidationSuite/archive/rocm-$pkgver.tar.gz"
+ "action.patch")
+sha256sums=('17662028a4485b97e3ccaad5e94d20aaa2c3e9e3f741c7ebbf0f8b4cdebcc555'
+ '8edac06b0658c77f91ce77bbfbe539c4f001b27ab205aabcad91cbecf19bd4d0')
+
+prepare() {
+ cd "$srcdir/ROCmValidationSuite-rocm-$pkgver"
+ patch --forward --strip=1 --input="${srcdir}/action.patch"
+}
build() {
mkdir -p "$srcdir/build"