summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAkash Patel2022-07-17 05:07:52 -0500
committerGitHub2022-07-17 12:07:52 +0200
commite541b825fb5afd28cdf8d09d89f648303915486c (patch)
tree0639b5c882810fb1b3e2a7a7bd90986265df50c6 /PKGBUILD
parent6709f5835dfdee513fb420e717a7249614715dae (diff)
downloadaur-e541b825fb5afd28cdf8d09d89f648303915486c.tar.gz
upgpkg: rocm-validation-suite 5.2.0-1 (#816)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 19 insertions, 16 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 185898f8b005..e165e856b5ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: codyfish <fe27 at gmx dot net>
# Contributor: sofiageo <george at sofianos dot dev>
pkgname=rocm-validation-suite
-pkgver=5.1.3
+pkgver=5.2.0
pkgrel=1
pkgdesc="Tool for detecting and troubleshooting common problems affecting AMD GPUs"
arch=('x86_64')
@@ -11,33 +11,34 @@ license=('MIT')
depends=('pciutils' 'doxygen' 'rocblas' 'rocm-smi-lib' 'git' 'libpciaccess')
makedepends=('cmake' 'systemd')
options=(!staticlibs strip !lto)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/ROCm-Developer-Tools/ROCmValidationSuite/archive/rocm-$pkgver.tar.gz"
- "rvs-os-type.patch::https://github.com/acxz/ROCmValidationSuite/commit/eb1a4bf5de8d8ba25f21ee13d6af1c46416e3961.patch")
-sha256sums=('0140a4128c31749c078d9e1dc863cbbd690efc65843c34a4b80f0056e5b8c7b6'
+_git='https://github.com/ROCm-Developer-Tools/ROCmValidationSuite'
+source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz"
+ "rvs-os-type.patch::https://github.com/acxz/ROCmValidationSuite/commit/eb1a4bf5de8d8ba25f21ee13d6af1c46416e3961.patch"
+ "rocblas-header.patch::https://github.com/acxz/ROCmValidationSuite/commit/3522af8597773cb5071746401280b8d813ca12cc.patch")
+sha256sums=('2dfef5d66f544230957ac9aaf647b2f1dccf3cc7592cc322cae9fbdcf3321365'
+ 'SKIP'
'SKIP')
+_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
prepare() {
- cd "$srcdir/ROCmValidationSuite-rocm-$pkgver"
- patch --forward --strip=1 --input="${srcdir}/rvs-os-type.patch"
+ cd "$_dirname"
+ patch -Np1 -i "$srcdir/rvs-os-type.patch"
+ patch -Np1 -i "$srcdir/rocblas-header.patch"
}
build() {
- mkdir -p "$srcdir/build"
- cd "$srcdir/build"
-
# -fcf-protection is not supported by HIP, see
- # https://github.com/ROCm-Developer-Tools/HIP/blob/develop/docs/markdown/clang_options.md
+ # https://docs.amd.com/bundle/ROCm-Compiler-Reference-Guide-v5.2/page/Appendix_A.html
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
- cmake -DROCM_PATH=/opt/rocm \
+ cmake -B build -Wno-dev \
+ -S "$_dirname" \
-DCMAKE_INSTALL_PREFIX=/opt/rocm \
- "$srcdir/ROCmValidationSuite-rocm-$pkgver"
- make
+ -DBUILD_FILE_REORG_BACKWARD_COMPATIBILITY=OFF
+ make -C build
}
package() {
- cd "$srcdir/build"
-
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" make -C build install
# add links
install -d "$pkgdir/usr/bin"
@@ -45,4 +46,6 @@ package() {
for _fn in rvs; do
ln -s "/opt/rocm/rvs/$_fn" "$pkgdir/usr/bin/$_fn"
done
+
+ install -Dm644 "$_dirname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}