summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2020-03-12 20:36:42 -0400
committeracxz2020-03-12 20:36:42 -0400
commitf0fe9981dc4b1cb1f73b07d3a2fa68177858bbb1 (patch)
tree4521888d67dacaa7718c041d3c1cc3a6e2a460bc /PKGBUILD
downloadaur-f0fe9981dc4b1cb1f73b07d3a2fa68177858bbb1.tar.gz
create rocm-validation-suite package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de0b8453a6c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: acxz <akashpatel2008 at yahoo dot com>
+pkgname=rocm-validation-suite
+pkgver=3.2.0
+pkgrel=1
+pkgdesc="Tool for detecting and troubleshooting common problems affecting AMD
+GPUs"
+arch=('x86_64')
+url="https://github.com/ROCm-Developer-Tools/ROCmValidationSuite"
+license=('MIT')
+depends=('pciutils' 'doxygen' 'rocblas' 'rocm-smi-lib' 'git')
+makedepends=('cmake')
+options=(!staticlibs strip)
+source=("rocm_validation_suite-roc-$pkgver.tar.gz::https://github.com/ROCm-Developer-Tools/ROCmValidationSuite/archive/roc-$pkgver.tar.gz")
+sha256sums=('be0e4bc1910a6e91119c2f26398b25efaa1c3943cd14ee3272bcd1838d416a33')
+
+build() {
+ mkdir -p "$srcdir/build"
+ cd "$srcdir/build"
+
+ cmake -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/opt/rocm/rvs \
+ "$srcdir/ROCmValidationSuite-roc-$pkgver"
+ make
+}
+
+package() {
+ cd "$srcdir/build"
+
+ make DESTDIR="$pkgdir" install
+
+ # add links
+ install -d "$pkgdir/usr/bin"
+ local _fn
+ for _fn in rocm_validation_suite; do
+ ln -s "/opt/rocm/rvs/bin/$_fn" "$pkgdir/usr/bin/$_fn"
+ done
+}