summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTorsten Keßler2021-11-07 16:26:14 +0100
committerTorsten Keßler2021-11-07 16:26:14 +0100
commit8a499e3b1acb191f1ad4e911b9c85bcadb6c9b60 (patch)
tree329484e59d7e020c12fc8a836b3daa379819ac82 /PKGBUILD
parent7232ea47d903e99bd7abbd0ce247a3995c04dfe6 (diff)
downloadaur-8a499e3b1acb191f1ad4e911b9c85bcadb6c9b60.tar.gz
upgpkg: rocprim 4.5.0-1
upstream release
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f3f2419f967b..4e5d7879eb1c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,21 @@
# Maintainer: Torsten Keßler <t dot kessler at posteo dot de>
# Contributor: Markus Näther <naetherm@informatik.uni-freiburg.de>
pkgname=rocprim
-pkgver=4.3.1
+pkgver=4.5.0
pkgrel=1
pkgdesc='Header-only library providing HIP parallel primitives'
arch=('x86_64')
url="https://github.com/ROCmSoftwarePlatform/rocPRIM"
license=('MIT')
-depends=('hip-rocclr')
+depends=('hip')
makedepends=('cmake' 'git')
source=("$pkgname-$pkgver.tar.gz::$url/archive/rocm-$pkgver.tar.gz")
-sha256sums=('d29ffcb5dd1c6155c586b9952fa4c11b717d90073feb083db6b03ea74746194b')
+sha256sums=('6f0ca1da9a93064af662d6c61fbdb56bb313f8edca85615ead0dd284eb481089')
_dirname="$(basename "$url")-$(basename "${source[0]}" ".tar.gz")"
build() {
# -fcf-protection is not supported by HIP, see
- # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-4.3.x/docs/markdown/clang_options.md
+ # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-4.5.x/docs/markdown/clang_options.md
# With version 3.21, HIP support was added to CMake that breaks the current scripts, see
# https://github.com/ROCmSoftwarePlatform/rocRAND/issues/198#issuecomment-893573440