summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGabriel Ortega2022-04-22 19:50:30 +0200
committerGabriel Ortega2022-04-22 19:50:30 +0200
commitcbca9ea97df39f92fa264f07dc747a3f5a3f6030 (patch)
treea8514c4654e1a8aac72397f2a9535853e723b291 /PKGBUILD
downloadaur-cbca9ea97df39f92fa264f07dc747a3f5a3f6030.tar.gz
first release for arch
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 45 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d788e48d734
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Gabriel Ortega <coffelius@gmail.com>
+pkgname=rofi-code-git
+pkgrel=1
+epoch=
+pkgver=0.2.r1.gf804543
+pkgdesc="Use rofi to quickly open Visual Studio Code or Codium workspaces."
+arch=($CARCH)
+url="https://www.github.com/Coffelius/rofi-code"
+license=('MIT')
+groups=()
+depends=()
+makedepends=(
+ 'git'
+ 'go'
+ )
+checkdepends=()
+optdepends=()
+provides=(rofi-code)
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("${pkgname}::git+$url")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ make dist
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -DT rofi-code "${pkgdir}/usr/bin/rofi-code"
+ install -DT LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -DT README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}