summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorDaniel M. Capella2022-10-28 01:37:25 -0400
committerDaniel M. Capella2022-10-28 01:37:25 -0400
commitc5d8c7c2ea757e01fde0a0d913a6236f13146f33 (patch)
tree433edd440aedf214b690210480a6d5139a0811d5 /PKGBUILD
parent96c05027d8eda36ed10bb8d07b6c9edaed516701 (diff)
downloadaur-c5d8c7c2ea757e01fde0a0d913a6236f13146f33.tar.gz
Bump
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 6 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 17338950b53c..6f94c286bde7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
# Maintainer: Daniel M. Capella <polyzen@archlinux.org>
pkgname=rofimoji-git
-pkgver=5.2.0.r0.g540ae53
+pkgver=6.0.0.rc1.r3.gd48f152
pkgrel=1
pkgdesc='Character picker for rofi'
arch=('any')
url=https://github.com/fdw/rofimoji
license=('MIT')
depends=('python-configargparse')
-makedepends=('git' 'python-build' 'python-install' 'python-setuptools'
- 'python-wheel')
+makedepends=('git' 'python-build' 'python-installer' 'python-poetry-core')
optdepends=('emoji-font: for the emojis character file'
'nerd-fonts: for the nerd_font character file'
'rofi: for the X.Org selector'
@@ -32,8 +31,8 @@ pkgver() {
prepare() {
cd ${pkgname%-git}
- # Remove data_files section https://github.com/pypa/wheel/issues/92
- sed -i '/\[options.data_files\]/,/^$/d' setup.cfg
+ # Remove include list https://github.com/pypa/wheel/issues/92
+ sed -i '/^include =/,/]/d' pyproject.toml
}
build() {
@@ -43,19 +42,13 @@ build() {
package() {
cd ${pkgname%-git}
- export PYTHONHASHSEED=0
- python -m install --optimize=1 --destdir="$pkgdir" dist/*.whl
+ python -m installer --destdir="$pkgdir" dist/*.whl
install -Dm644 -t "$pkgdir"/usr/share/man/man1 \
src/picker/docs/${pkgname%-git}.1
- # https://github.com/FFY00/python-install/pull/6
- chmod +x "$pkgdir"/usr/bin/*
-
# Symlink license file
local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
install -d "$pkgdir"/usr/share/licenses/$pkgname
- ln -s $site_packages/${pkgname%-git}-${pkgver%%.r*}.dist-info/LICENSE \
+ ln -s "$site_packages"/${pkgname%-git}-6.0.0rc1.dist-info/LICENSE \
"$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-
-# vim:set ts=2 sw=2 et: