summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorStaticRocket2020-04-14 19:45:11 -0400
committerStaticRocket2020-04-14 19:45:11 -0400
commited3d1efc4bf42af5858a6c57b3af11ace3d79e4e (patch)
tree21b25c5e0a251b9deeca3e479681757527d3319c /PKGBUILD
parent20d06369e0f19d2f13ecc7201991c1e5edafe055 (diff)
downloadaur-ed3d1efc4bf42af5858a6c57b3af11ace3d79e4e.tar.gz
added udev rules
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb748d376d4e..ad67cb99c4ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,10 +7,10 @@ pkgdesc="RGB keyboard control for Asus ROG laptops"
arch=('x86_64')
url="https://github.com/wroberts/rogauracore"
license=('MIT')
-depends=('libusb')
+depends=('glibc' 'libusb' 'udev')
makedepends=('git')
-source=('git+https://github.com/wroberts/rogauracore.git')
-md5sums=('SKIP')
+source=('git+https://github.com/wroberts/rogauracore.git' '90-rogauracore.rules')
+md5sums=('SKIP' 'acf8f96f46cbd14c5d208594684a69e4')
_gitdir=${pkgname%"-git"}
pkgver() {
@@ -28,4 +28,7 @@ build() {
package() {
cd "$_gitdir"
make DESTDIR="$pkgdir/" install
+ cd "$srcdir"
+ install -Dm644 90-rogauracore.rules "$pkgdir/usr/lib/udev/rules.d/90-rogauracore.rules"
}
+