summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMatt Mathis2020-01-01 18:27:04 -0500
committerMatt Mathis2020-01-01 18:27:04 -0500
commit6f0dbf7d824c07a650d5d2f1b80c296a015b592a (patch)
treeafc7e65c2c93d2e5e6c9e4fd3063e4cb02a58a4e /PKGBUILD
parent136be1527e3d7251857d5379440548bac0481ca2 (diff)
downloadaur-6f0dbf7d824c07a650d5d2f1b80c296a015b592a.tar.gz
Moved to meson build system
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2bd15bad9f09..689c5b7d4671 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ arch=('x86_64')
url="https://hg.sr.ht/~scoopta/rootbar"
license=('GPL3')
depends=('wayland' 'gtk3' 'json-c' 'libpulse')
-makedepends=('mercurial')
+makedepends=('mercurial' 'meson')
source=("${pkgname}::hg+$url")
sha256sums=('SKIP')
pkgver() {
@@ -15,9 +15,10 @@ pkgver() {
}
build() {
cd "${pkgname}/Release"
- make
+ meson build
+ ninja -C build
}
package() {
mkdir -p "$pkgdir/usr/bin"
- cp ${pkgname}/Release/rootbar "$pkgdir/usr/bin/"
+ cp ${pkgname}/build/rootbar "$pkgdir/usr/bin/"
} \ No newline at end of file