summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLevente Polyak2023-12-03 14:51:00 +0100
committerLevente Polyak2023-12-03 14:51:19 +0100
commitbd73497a4bb8bbb0e6608b90adbb18713c7ed3ab (patch)
tree05f023d02e7664143c18c14d7111069ab64d9fad /PKGBUILD
parentd51828b50617ef369affddb59b12b5a8b2d9e984 (diff)
downloadaur-ropgadget-git.tar.gz
updpkg: 7.4.542.0fd62cc
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 14 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 46c28b820ae3..78d37446fda9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: Levente Polyak <levente[at]leventepolyak[dot]net>
pkgname=ropgadget-git
-pkgver=5.4.348.282d851
+pkgver=7.4.542.0fd62cc
pkgrel=1
pkgdesc="Search gadgets in binaries to facilitate ROP exploitation for several file formats and architectures"
url="http://www.shell-storm.org/project/ROPgadget"
arch=('any')
-license=('GPL2')
-depends=('python-capstone')
-makedepends=('git' 'python-setuptools')
+license=('BSD')
+depends=('python' 'python-capstone')
+makedepends=('git' 'python-setuptools' 'python-build' 'python-installer' 'python-wheel')
provides=('ropgadget')
conflicts=('ropgadget')
source=(${pkgname}::git+https://github.com/JonathanSalwan/ROPgadget)
@@ -19,14 +19,21 @@ pkgver() {
printf "%s.%s.%s" "$(git describe --tags --abbrev=0|cut -dv -f2)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+build() {
+ cd ${pkgname}
+ python -m build --wheel --no-isolation
+}
+
check() {
- cd ${pkgname}/test-suite-binaries
- ./test.sh
+ cd ${pkgname}
+ ./ROPgadget.py --binary ./test-suite-binaries/elf-Linux-x86 --string "main"
}
package() {
cd ${pkgname}
- python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ install -Dm 644 LICENSE_BSD.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"
}
# vim:set ts=2 sw=2 et: