summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChristopher Andronikos2015-12-19 13:06:28 +1100
committerChristopher Andronikos2015-12-19 13:06:28 +1100
commit7e358008bac570f6b14979852454b4f5c3a28175 (patch)
treea0a1460589343703c9c806cdcf0e753e59fef1be /PKGBUILD
downloadaur-7e358008bac570f6b14979852454b4f5c3a28175.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD58
1 files changed, 58 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f04f435a90dd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,58 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Asynchronous Web/WebSocket Server in C++."
+url='http://ros.org/wiki/async_web_server_cpp'
+
+pkgname='ros-indigo-async-web-server-cpp'
+pkgver='0.0.3'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-indigo-catkin)
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ boost
+ openssl)
+
+ros_depends=()
+depends=(${ros_depends[@]}
+ python2-websocket
+ boost
+ openssl)
+
+_tag=release/indigo/async_web_server_cpp/${pkgver}-${_pkgver_patch}
+_dir=async_web_server_cpp
+source=("${_dir}"::"git+https://github.com/wpi-rail-release/async_web_server_cpp-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/indigo/setup.bash ] && source /opt/ros/indigo/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}