summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-07 16:09:52 +0200
committerBenjamin Chrétien2014-06-07 16:09:55 +0200
commit8c9ee18d60d47ff8c51a22a8936e61dc58b2000f (patch)
tree6e474057d94ae8b663d84ea5281b6fe3b40edcc2 /PKGBUILD
parent0c7fea8b9b85e70c3c5f8c5638c4ac157627d1b8 (diff)
downloadaur-8c9ee18d60d47ff8c51a22a8936e61dc58b2000f.tar.gz
indigo: use Python 2 rather than Python 3.
Since most packages are unlikely to be Python 3 ready before the next ROS distribution, we stick to Python 2.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89cd4ddce2ba..1667061d2ef5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-indigo-mk'
pkgver='1.11.1'
_pkgver_patch=1
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD')
ros_makedepends=(ros-indigo-catkin)
@@ -32,16 +32,16 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.4m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.4m.so \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}