summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Chrétien2016-03-24 11:02:01 +0900
committerBenjamin Chrétien2016-03-24 11:02:01 +0900
commitc75014b73f2a9eb98ade5a07d57ae76b3db18500 (patch)
tree75695b1150dd87a8c700612a2f5aa5585827dc3b /PKGBUILD
parent7cd34f9c2a88bf284b9192e93e11bce3eee7336f (diff)
downloadaur-c75014b73f2a9eb98ade5a07d57ae76b3db18500.tar.gz
Update to version 2.2.6 (pkgrel 1)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51d2524c82fd..a6f232d71e67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,15 @@ pkgdesc="ROS - ROS Package Tool."
url='http://wiki.ros.org/rospack'
pkgname='ros-indigo-rospack'
-pkgver='2.2.5'
+pkgver='2.2.6'
_pkgver_patch=0
arch=('any')
-pkgrel=5
+pkgrel=1
license=('BSD')
ros_makedepends=(ros-indigo-cmake-modules
ros-indigo-catkin)
-makedepends=('cmake' 'git' 'ros-build-tools'
+makedepends=('cmake' 'ros-build-tools'
${ros_makedepends[@]}
gtest
pkg-config
@@ -22,17 +22,23 @@ makedepends=('cmake' 'git' 'ros-build-tools'
ros_depends=()
depends=(${ros_depends[@]}
+ python2-catkin-pkg
python2-rosdep
tinyxml
- python2-catkin-pkg
python2
boost
pkg-config)
-_tag=release/indigo/rospack/${pkgver}-${_pkgver_patch}
-_dir=rospack
-source=("${_dir}"::"git+https://github.com/ros-gbp/rospack-release.git"#tag=${_tag})
-md5sums=('SKIP')
+# Git version (e.g. for debugging)
+# _tag=release/indigo/rospack/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/rospack-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rospack-release-release-indigo-rospack-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rospack-release/archive/release/indigo/rospack/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('502e69d105750724732bad915d1d7242707b45e722c8b20685e81e80998fdf5b')
build() {
# Use ROS environment variables
@@ -54,6 +60,7 @@ build() {
-DPYTHON_EXECUTABLE=/usr/bin/python2 \
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}