summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Chrétien2014-06-07 16:09:52 +0200
committerBenjamin Chrétien2014-06-07 16:09:55 +0200
commite364a9ee84e0ec9eac95b5af60fdd6e6e11493c3 (patch)
tree75f14176070f0c18394b64849a5fc0a149f4d323 /PKGBUILD
parentf0a5f257f7c091b2b68e01c6a85f8cba9cc8f29d (diff)
downloadaur-e364a9ee84e0ec9eac95b5af60fdd6e6e11493c3.tar.gz
indigo: use Python 2 rather than Python 3.
Since most packages are unlikely to be Python 3 ready before the next ROS distribution, we stick to Python 2.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD26
1 files changed, 13 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a7756de0ecd2..4bd61d11dae6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,26 +7,26 @@ pkgname='ros-indigo-rospack'
pkgver='2.2.3'
_pkgver_patch=1
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD')
-ros_makedepends=(ros-indigo-catkin
- ros-indigo-cmake-modules)
+ros_makedepends=(ros-indigo-cmake-modules
+ ros-indigo-catkin)
makedepends=('cmake' 'git' 'ros-build-tools'
${ros_makedepends[@]}
gtest
- tinyxml
pkg-config
boost
- python)
+ tinyxml
+ python2)
ros_depends=()
depends=(${ros_depends[@]}
- python-catkin-pkg
- python-rosdep
- boost
- python
+ python2-rosdep
tinyxml
+ python2-catkin_pkg
+ python2
+ boost
pkg-config)
_tag=release/indigo/rospack/${pkgver}-${_pkgver_patch}
@@ -44,16 +44,16 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/indigo \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.4m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.4m.so \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}