summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBenjamin Chrétien2015-06-20 21:48:33 +0900
committerBenjamin Chrétien2015-06-20 21:48:33 +0900
commitf9ad50e0fffd93327e061adff2bf243ad9e3addd (patch)
tree305955676fe378be6441e11bad29aa2f2ad76f10 /PKGBUILD
downloadaur-f9ad50e0fffd93327e061adff2bf243ad9e3addd.tar.gz
jade: add desktop_full and its dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD56
1 files changed, 56 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..21e9ee42835e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,56 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - PCL (Point Cloud Library) ROS interface stack."
+url='http://ros.org/wiki/perception_pcl'
+
+pkgname='ros-jade-perception-pcl'
+pkgver='1.2.6'
+_pkgver_patch=1
+arch=('any')
+pkgrel=2
+license=('BSD')
+
+ros_makedepends=(ros-jade-catkin)
+makedepends=('cmake' 'git' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-jade-pointcloud-to-laserscan
+ ros-jade-pcl-msgs
+ ros-jade-pcl-ros
+ ros-jade-pcl-conversions)
+depends=(${ros_depends[@]})
+
+_tag=release/jade/perception_pcl/${pkgver}-${_pkgver_patch}
+_dir=perception_pcl
+source=("${_dir}"::"git+https://github.com/ros-gbp/perception_pcl-release.git"#tag=${_tag})
+md5sums=('SKIP')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/jade/setup.bash ] && source /opt/ros/jade/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/jade \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}