summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBen Wolsieffer2019-01-10 21:00:52 -0500
committerBen Wolsieffer2019-01-10 21:02:45 -0500
commit667e8a82b46cb67e5cf158341e8ba5ae83fe0681 (patch)
tree01c4949e6465befa5deb90d4903ca97320e676cf /PKGBUILD
parent6ba72208230c58814055e64deb8e9776a4700551 (diff)
downloadaur-667e8a82b46cb67e5cf158341e8ba5ae83fe0681.tar.gz
Fix build failures with latest CMake.
Applies https://github.com/ros/catkin/pull/975 as a fix.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 82127883e73d..37990c071f27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-kinetic-catkin'
pkgver='0.7.11'
_pkgver_patch=0
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=()
@@ -34,8 +34,15 @@ depends=(${ros_depends[@]}
# Tarball version (faster download)
_dir="catkin-release-release-kinetic-catkin-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/catkin-release/archive/release/kinetic/catkin/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('54cba1b4b0d1ec74d168004e44a002e2f0a6d3794f455605c466f8f8ef911d20')
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/catkin-release/archive/release/kinetic/catkin/${pkgver}-${_pkgver_patch}.tar.gz"
+ "cmake-fix.patch"::"https://github.com/ros/catkin/commit/28efc5584d5df89b990b9deb247e794ad55455ca.patch")
+sha256sums=('54cba1b4b0d1ec74d168004e44a002e2f0a6d3794f455605c466f8f8ef911d20'
+ '64a38284f056d48341611bf231f12ba56e155d9f03f551458ff9f07dc0831e3f')
+
+prepare() {
+ cd "${srcdir}/${_dir}"
+ patch -p1 -i "${srcdir}/cmake-fix.patch"
+}
build() {
# Use ROS environment variables