summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSean Greenslade2016-12-20 21:47:37 -0800
committerSean Greenslade2016-12-20 21:47:37 -0800
commit37ac7bd9449215268158acff0ad72e76e34e66df (patch)
tree61e80f5dacb14893c0cf9469219805fdfcf1e89e /PKGBUILD
downloadaur-37ac7bd9449215268158acff0ad72e76e34e66df.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD68
1 files changed, 68 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4435b01ab6ef
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,68 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - This contains CvBridge, which converts between ROS Image messages and OpenCV images."
+url='http://www.ros.org/wiki/cv_bridge'
+
+pkgname='ros-kinetic-cv-bridge'
+pkgver='1.12.3'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-catkin
+ ros-kinetic-opencv3
+ ros-kinetic-rosconsole
+ ros-kinetic-sensor-msgs)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ boost
+ python2)
+
+ros_depends=(ros-kinetic-opencv3
+ ros-kinetic-rosconsole
+ ros-kinetic-sensor-msgs)
+depends=(${ros_depends[@]}
+ boost
+ python2)
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/cv_bridge/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/vision_opencv-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="vision_opencv-release-release-kinetic-cv_bridge-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/vision_opencv-release/archive/release/kinetic/cv_bridge/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('7559068ede840c0b2c7f5024d4a31c610ef4098bff059eb3fc24508a2ac6101a')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}