summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSean Greenslade2017-09-10 20:16:16 -0700
committerSean Greenslade2017-09-10 20:16:16 -0700
commit94a90c1b82e1e553b4f012bc381ade779613fb53 (patch)
tree6e911873608bb0f3ae90794bcf0957fb67948f51 /PKGBUILD
downloadaur-94a90c1b82e1e553b4f012bc381ade779613fb53.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 66 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e78fd73a8a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - forward_command_controller."
+url='https://github.com/ros-controls/ros_controllers/wiki'
+
+pkgname='ros-kinetic-forward-command-controller'
+pkgver='0.13.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-realtime-tools
+ ros-kinetic-controller-interface
+ ros-kinetic-catkin
+ ros-kinetic-std-msgs
+ ros-kinetic-hardware-interface)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-kinetic-realtime-tools
+ ros-kinetic-controller-interface
+ ros-kinetic-std-msgs
+ ros-kinetic-hardware-interface)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/forward_command_controller/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_controllers-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros_controllers-release-release-kinetic-forward_command_controller-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_controllers-release/archive/release/kinetic/forward_command_controller/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('7a61ce8c69706d93d4505e2045c5e907c5f253c4cbf0fd3b2278dfad0323a8ce')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}