summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormajor major2019-03-11 19:21:49 +0100
committermajor major2019-03-11 19:21:49 +0100
commit61bfb59720a6ec9ff98b742b5ae535adfc665b84 (patch)
treee188f2e3863b349c88635c737ed26c6c091aa1e6 /PKGBUILD
parent74d741554a148b93bee2adde6fac93c3de34d56a (diff)
downloadaur-ros-kinetic-gmapping.tar.gz
fixed boost signal issue
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 10 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a4e18b28b18..8709a47af70b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ pkgdesc="ROS - This package contains a ROS wrapper for OpenSlams Gmapping."
url='http://ros.org/wiki/gmapping'
pkgname='ros-kinetic-gmapping'
-pkgver='1.3.8'
+pkgver='1.3.10'
_pkgver_patch=0
arch=('any')
pkgrel=1
@@ -27,8 +27,15 @@ depends=(${ros_depends[@]})
_tag=release/kinetic/gmapping/${pkgver}-${_pkgver_patch}
_dir=gmapping
-source=("${_dir}"::"git+https://github.com/ros-gbp/slam_gmapping-release.git"#tag=${_tag})
-md5sums=('SKIP')
+source=("${_dir}"::"git+https://github.com/ros-gbp/slam_gmapping-release.git"#tag=${_tag}
+ 'gmapping_boost.patch')
+md5sums=('SKIP'
+ 'SKIP')
+
+prepare() {
+ cd "${srcdir}/${_dir}"
+ patch -Np1 -i "${srcdir}/gmapping_boost.patch"
+}
build() {
# Use ROS environment variables