summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSean Greenslade2016-12-20 21:37:11 -0800
committerSean Greenslade2016-12-20 21:37:11 -0800
commita61f86024a7af5b122fdf3954bf6b1f6f01685fa (patch)
treecafdec2cc5e2490a69b81daa8ee6899949e4fd4c /PKGBUILD
downloadaur-a61f86024a7af5b122fdf3954bf6b1f6f01685fa.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD78
1 files changed, 78 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0136412f42b4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,78 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - The nodelet package is designed to provide a way to run multiple algorithms in the same process with zero copy transport between algorithms."
+url='http://ros.org/wiki/nodelet'
+
+pkgname='ros-kinetic-nodelet'
+pkgver='1.9.8'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-cmake-modules
+ ros-kinetic-std-msgs
+ ros-kinetic-bondcpp
+ ros-kinetic-message-generation
+ ros-kinetic-roscpp
+ ros-kinetic-rospy
+ ros-kinetic-pluginlib
+ ros-kinetic-rosconsole
+ ros-kinetic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ util-linux
+ boost
+ tinyxml)
+
+ros_depends=(ros-kinetic-bondcpp
+ ros-kinetic-roscpp
+ ros-kinetic-message-runtime
+ ros-kinetic-std-msgs
+ ros-kinetic-pluginlib
+ ros-kinetic-rosconsole)
+depends=(${ros_depends[@]}
+ util-linux
+ boost
+ tinyxml)
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/nodelet/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/nodelet_core-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="nodelet_core-release-release-kinetic-nodelet-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/nodelet_core-release/archive/release/kinetic/nodelet/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('e3364796c04d51af007f85bf1b5dab5861a236a13c974d14defb43b114f702db')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}