summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSean Greenslade2016-12-20 21:36:15 -0800
committerSean Greenslade2016-12-20 21:36:15 -0800
commitf47ec169aaa66aa79809ed7252139b1a8242e5b1 (patch)
treeeafb3a3bf50ab0225feb63de99d032afc9a6305b /PKGBUILD
downloadaur-ros-kinetic-ros-comm.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD80
1 files changed, 80 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..54b9bbb1a8e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,80 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - ROS communications-related packages, including core client libraries (roscpp, rospy) and graph introspection tools (rostopic, rosnode, rosservice, rosparam)."
+url='http://www.ros.org/wiki/ros_comm'
+
+pkgname='ros-kinetic-ros-comm'
+pkgver='1.12.6'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-kinetic-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-kinetic-rosparam
+ ros-kinetic-rosout
+ ros-kinetic-rostest
+ ros-kinetic-roslaunch
+ ros-kinetic-ros
+ ros-kinetic-rosservice
+ ros-kinetic-roslisp
+ ros-kinetic-rosgraph-msgs
+ ros-kinetic-std-srvs
+ ros-kinetic-rosnode
+ ros-kinetic-rosmaster
+ ros-kinetic-rospy
+ ros-kinetic-rosbag
+ ros-kinetic-rosgraph
+ ros-kinetic-message-filters
+ ros-kinetic-roswtf
+ ros-kinetic-topic-tools
+ ros-kinetic-rosconsole
+ ros-kinetic-roscpp
+ ros-kinetic-rostopic
+ ros-kinetic-xmlrpcpp
+ ros-kinetic-rosmsg)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/kinetic/ros_comm/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros_comm-release-release-kinetic-ros_comm-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/kinetic/ros_comm/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('b143b275955b3cf73ea9e3942561da140a25959c1a8de2b8990a5d0a38b72b31')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/kinetic/setup.bash ] && source /opt/ros/kinetic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/kinetic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}