summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:47:22 +0200
committerTim Rakowski2017-05-22 19:26:27 +0200
commit66145f7e44b9acb4fbedd735b3683f34eef2bc9f (patch)
tree3080b3fb8a946310bcba8d5aec55a80d39b9efa5 /PKGBUILD
downloadaur-66145f7e44b9acb4fbedd735b3683f34eef2bc9f.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD65
1 files changed, 65 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..100bfa519478
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - qt_gui_cpp provides the foundation for C++-bindings for qt_gui and creates bindings for every generator available."
+url='http://ros.org/wiki/qt_gui_cpp'
+
+pkgname='ros-lunar-qt-gui-cpp'
+pkgver='0.3.4'
+_pkgver_patch=2
+arch=('any')
+pkgrel=3
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin
+ ros-lunar-python-qt-binding
+ ros-lunar-pluginlib)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ tinyxml
+ qt5-base
+ pkg-config)
+
+ros_depends=(ros-lunar-qt-gui
+ ros-lunar-pluginlib)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/qt_gui_cpp/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/qt_gui_core-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="qt_gui_core-release-release-lunar-qt_gui_cpp-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/qt_gui_core-release/archive/release/lunar/qt_gui_cpp/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('58b32dedd5c384952bd475a03491100dcf70f4320144e878a4d9a96840ab841b')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}