summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:40:44 +0200
committerTim Rakowski2017-05-22 19:26:27 +0200
commit6d68551997c4dfe52e6eedf0fe592a93ed92b2c7 (patch)
tree6febb63b4cf1c31720d1030569c4d674dbce04e5 /PKGBUILD
downloadaur-6d68551997c4dfe52e6eedf0fe592a93ed92b2c7.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD80
1 files changed, 80 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..239ed3e03025
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,80 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - ROS communications-related packages, including core client libraries (roscpp, rospy) and graph introspection tools (rostopic, rosnode, rosservice, rosparam)."
+url='http://www.ros.org/wiki/ros_comm'
+
+pkgname='ros-lunar-ros-comm'
+pkgver='1.13.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-lunar-rosgraph
+ ros-lunar-rospy
+ ros-lunar-roswtf
+ ros-lunar-rostopic
+ ros-lunar-std-srvs
+ ros-lunar-rosparam
+ ros-lunar-roscpp
+ ros-lunar-roslisp
+ ros-lunar-topic-tools
+ ros-lunar-rosconsole
+ ros-lunar-xmlrpcpp
+ ros-lunar-ros
+ ros-lunar-rosout
+ ros-lunar-rostest
+ ros-lunar-rosmaster
+ ros-lunar-rosbag
+ ros-lunar-rosservice
+ ros-lunar-message-filters
+ ros-lunar-roslaunch
+ ros-lunar-rosgraph-msgs
+ ros-lunar-rosmsg
+ ros-lunar-rosnode)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/ros_comm/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros_comm-release-release-lunar-ros_comm-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/lunar/ros_comm/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('c3aeaa5e8ba820bb34894e075779348d70c17dfcb81c30c29fba2e675834a797')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}