summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:39:11 +0200
committerTim Rakowski2017-05-22 19:26:26 +0200
commitd51324fe34dd3598a8168ed8f7bd3887d4271f45 (patch)
treee30ecd42cbc9b8debfcd3954c5ad2da4c9785bcc /PKGBUILD
downloadaur-d51324fe34dd3598a8168ed8f7bd3887d4271f45.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 62 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a74d9e9c43a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Messages relating to the ROS Computation Graph."
+url='http://ros.org/wiki/rosgraph_msgs'
+
+pkgname='ros-lunar-rosgraph-msgs'
+pkgver='1.11.2'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-std-msgs
+ ros-lunar-catkin
+ ros-lunar-message-generation)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-lunar-message-runtime
+ ros-lunar-std-msgs)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/rosgraph_msgs/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm_msgs-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros_comm_msgs-release-release-lunar-rosgraph_msgs-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm_msgs-release/archive/release/lunar/rosgraph_msgs/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('1a0d3852c1e703a72777666c2acd122dc75d264177cdd31e2a5201250f4baa57')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}