summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:39:47 +0200
committerTim Rakowski2017-05-22 19:26:27 +0200
commit3680c320a18354405ff2119bb6071b6b5a95358f (patch)
tree625e8a9c933452b2db8ef60cedad764d11c61733 /PKGBUILD
downloadaur-3680c320a18354405ff2119bb6071b6b5a95358f.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 66 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b006532fc8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Integration test suite based on roslaunch that is compatible with xUnit frameworks."
+url='http://ros.org/wiki/rostest'
+
+pkgname='ros-lunar-rostest'
+pkgver='1.13.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin
+ ros-lunar-rosunit)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ boost)
+
+ros_depends=(ros-lunar-rosmaster
+ ros-lunar-roslaunch
+ ros-lunar-rosunit
+ ros-lunar-rospy
+ ros-lunar-rosgraph)
+depends=(${ros_depends[@]}
+ boost)
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/rostest/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/ros_comm-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="ros_comm-release-release-lunar-rostest-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/ros_comm-release/archive/release/lunar/rostest/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('9bd208b6c9937f0cd3b812ba6a4a3323e330ef66220ffc7a01a393e6e5c92bad')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}