summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:47:25 +0200
committerTim Rakowski2017-05-22 19:26:26 +0200
commit8500d2cc23e305710b77dcb54fe8bdd6c2ff371c (patch)
treea1d7f4f205196d86b60333fe6ac695cc3bce3c82 /PKGBUILD
downloadaur-ros-lunar-rqt-gui-cpp.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD67
1 files changed, 67 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..accf0b1682ba
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,67 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - rqt_gui_cpp enables GUI plugins to use the C++ client library for ROS."
+url='http://ros.org/wiki/rqt_gui_cpp'
+
+pkgname='ros-lunar-rqt-gui-cpp'
+pkgver='0.5.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-catkin
+ ros-lunar-qt-gui
+ ros-lunar-nodelet
+ ros-lunar-roscpp
+ ros-lunar-qt-gui-cpp)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ qt5-base)
+
+ros_depends=(ros-lunar-qt-gui
+ ros-lunar-nodelet
+ ros-lunar-roscpp
+ ros-lunar-qt-gui-cpp)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/rqt_gui_cpp/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/rqt-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="rqt-release-release-lunar-rqt_gui_cpp-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/rqt-release/archive/release/lunar/rqt_gui_cpp/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('522a720f3db0b4465af08f55bd3105c1f95146d4b87a72f66b05b93585cdccfb')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}