summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTim Rakowski2017-05-20 10:37:48 +0200
committerTim Rakowski2017-05-22 19:26:28 +0200
commitc951d1cb889b517eb773a488a7bb64d8273575a9 (patch)
treed6a6afd12e65166fc41ce5118536888969a00c06 /PKGBUILD
downloadaur-ros-lunar-sensor-msgs.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD64
1 files changed, 64 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9fba663551f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,64 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - This package defines messages for commonly used sensors, including cameras and scanning laser rangefinders."
+url='http://ros.org/wiki/sensor_msgs'
+
+pkgname='ros-lunar-sensor-msgs'
+pkgver='1.12.5'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-lunar-message-generation
+ ros-lunar-std-msgs
+ ros-lunar-geometry-msgs
+ ros-lunar-catkin)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-lunar-std-msgs
+ ros-lunar-message-runtime
+ ros-lunar-geometry-msgs)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/lunar/sensor_msgs/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/common_msgs-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="common_msgs-release-release-lunar-sensor_msgs-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/common_msgs-release/archive/release/lunar/sensor_msgs/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('c80efd453f93e150b06d0cb1d2817fc3de6c132df539d8d45f19db2c5ef84554')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}