summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTim Rakowski2017-12-12 21:51:11 +0100
committerTim Rakowski2017-12-12 21:51:11 +0100
commit21ce5a4f18abc8b42694714263f52e7c3729bc88 (patch)
tree1a9cb905c721a0a9468fb26ce74a359ec5a90bb4 /PKGBUILD
parent3bd6dbece61ff5329f7a150736695f31b9ad2306 (diff)
downloadaur-ros-lunar-urdf.tar.gz
Update to version 1.12.12-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 15 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1cde0459951b..6834c3915314 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,42 +4,36 @@ pkgdesc="ROS - This package contains a C++ parser for the Unified Robot Descript
url='http://ros.org/wiki/urdf'
pkgname='ros-lunar-urdf'
-pkgver='1.12.11'
+pkgver='1.12.12'
_pkgver_patch=0
arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-lunar-rosconsole-bridge
- ros-lunar-catkin
- ros-lunar-roscpp
- ros-lunar-pluginlib
+ros_makedepends=(ros-lunar-catkin
ros-lunar-cmake-modules
- ros-lunar-rostest
ros-lunar-urdf-parser-plugin)
makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]}
- urdfdom
- urdfdom-headers)
+ ${ros_makedepends[@]})
ros_depends=(ros-lunar-rosconsole-bridge
ros-lunar-roscpp
- ros-lunar-pluginlib
- ros-lunar-urdf-parser-plugin)
+ ros-lunar-pluginlib)
depends=(${ros_depends[@]}
urdfdom
+ tinyxml
urdfdom-headers)
# Git version (e.g. for debugging)
# _tag=release/lunar/urdf/${pkgver}-${_pkgver_patch}
# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/robot_model-release.git"#tag=${_tag})
+# source=("${_dir}"::"git+https://github.com/ros-gbp/urdf-release.git"#tag=${_tag})
# sha256sums=('SKIP')
# Tarball version (faster download)
-_dir="robot_model-release-release-lunar-urdf-${pkgver}-${_pkgver_patch}"
-source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/robot_model-release/archive/release/lunar/urdf/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('daf1e720eb332684c7c6e5ef0fbee8f748fe1175c8db22afde948b5dcd9ef375')
+_dir="urdf-release-release-lunar-urdf-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/urdf-release/archive/release/lunar/urdf/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('215d05cb557935c5e9f60a34278d34cb12729efcdecf15e2029b91d9d7952999')
build() {
# Use ROS environment variables
@@ -47,14 +41,14 @@ build() {
[ -f /opt/ros/lunar/setup.bash ] && source /opt/ros/lunar/setup.bash
# Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ [ -d "${srcdir}/build" ] || mkdir "${srcdir}/build"
+ cd "${srcdir}/build"
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 "${srcdir}/${_dir}"
# Build project
- cmake ${srcdir}/${_dir} \
+ cmake "${srcdir}/${_dir}" \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/lunar \
@@ -62,7 +56,8 @@ build() {
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DPYTHON_BASENAME=-python2.7 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DCATKIN_ENABLE_TESTING=OFF
make
}