summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2019-09-22 13:13:08 -0400
committeracxz2019-09-22 13:13:08 -0400
commit975cc10445af8b77f4bd07940f9e34e6a57b6281 (patch)
tree6fa26dc77c38515420284d0d2e6580a1e36286bc /PKGBUILD
parent9d22ce863a1e6016040e978536a1474a2f3b256c (diff)
downloadaur-975cc10445af8b77f4bd07940f9e34e6a57b6281.tar.gz
Fix dependencies
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD67
1 files changed, 28 insertions, 39 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3c5a5768d3fa..2655328a15a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,62 +1,51 @@
# Maintainer: Timon Engelke <aur@timonengelke.de>
pkgdesc="ROS - This package provides an implementation of a 2D costmap."
-url='https://github.com/ros-planning/navigation'
+url='https://wiki.ros.org/costmap_2d'
pkgname='ros-melodic-costmap-2d'
pkgver='1.16.2'
arch=('any')
-pkgrel=3
+pkgrel=4
license=('BSD')
-ros_makedepends=(ros-melodic-message-filters
- ros-melodic-visualization-msgs
- ros-melodic-pcl-conversions
+ros_makedepends=(
+ ros-melodic-catkin
ros-melodic-cmake-modules
- ros-melodic-nav-msgs
ros-melodic-message-generation
- ros-melodic-tf
+ ros-melodic-tf2-geometry-msgs
ros-melodic-tf2-sensor-msgs
- ros-melodic-geometry-msgs
- ros-melodic-roscpp
- ros-melodic-std-msgs
- ros-melodic-pluginlib
+)
+
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
+
+ros_depends=(
ros-melodic-dynamic-reconfigure
+ ros-melodic-geometry-msgs
+ ros-melodic-laser-geometry
ros-melodic-map-msgs
- ros-melodic-sensor-msgs
- ros-melodic-voxel-grid
- ros-melodic-catkin
- ros-melodic-pcl-ros
- ros-melodic-laser-geometry)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]})
-
-ros_depends=(ros-melodic-message-filters
- ros-melodic-visualization-msgs
- ros-melodic-pcl-conversions
+ ros-melodic-message-filters
ros-melodic-nav-msgs
- ros-melodic-tf
- ros-melodic-tf2-sensor-msgs
- ros-melodic-geometry-msgs
- ros-melodic-roscpp
- ros-melodic-message-runtime
- ros-melodic-std-msgs
ros-melodic-pluginlib
- ros-melodic-dynamic-reconfigure
- ros-melodic-map-msgs
+ ros-melodic-roscpp
+ ros-melodic-rostest
ros-melodic-sensor-msgs
+ ros-melodic-std-msgs
+ ros-melodic-tf2
+ ros-melodic-tf2-ros
+ ros-melodic-visualization-msgs
ros-melodic-voxel-grid
- ros-melodic-pcl-ros
+ ros-melodic-message-runtime
ros-melodic-rosconsole
- ros-melodic-laser-geometry)
-depends=(${ros_depends[@]})
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/costmap_2d/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/navigation-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+depends=(
+ ${ros_depends[@]}
+)
-# Tarball version (faster download)
_dir="navigation-${pkgver}/costmap_2d"
source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-planning/navigation/archive/${pkgver}.tar.gz")
sha256sums=('d83201296e773e2789635fddf39ac18e9465219b18707e53bd2361de4762d205')