summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbionade242020-07-06 15:35:27 +0200
committerbionade242020-07-06 15:35:27 +0200
commit381181c9d54be792c876160a54497c2dae303750 (patch)
tree5ba3c6f27b3b94a5e2f2744f6690189bd09d6ff6 /PKGBUILD
parent07cf5a91d77f2f29e34091471108918d82ca7c24 (diff)
downloadaur-381181c9d54be792c876160a54497c2dae303750.tar.gz
Set python version to 3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d31a88f23aa8..c32099962ccb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-melodic-dynamic-edt-3d'
pkgver='1.9.0'
_pkgver_patch=1
arch=('any')
-pkgrel=2
+pkgrel=3
license=('BSD')
ros_makedepends=(ros-melodic-octomap)
@@ -39,14 +39,14 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DPYTHON_BASENAME=-python2.7 \