summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelix Exner2021-01-25 14:04:30 +0100
committerFelix Exner2021-01-25 14:04:30 +0100
commit36da1f1e918aa53b8168081d823c360d5dde6977 (patch)
tree3dde48e509b194f39470b4e9af1638b411ea48ca /PKGBUILD
parent0b074c336d2905667415b60c15115568fdcf3323 (diff)
downloadaur-36da1f1e918aa53b8168081d823c360d5dde6977.tar.gz
Setup boost paths during build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f33e9cf82fd4..849fd260bbed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ url='https://wiki.ros.org/fake_localization'
pkgname='ros-melodic-fake-localization'
pkgver='1.16.7'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=(
@@ -55,7 +55,9 @@ build() {
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DBOOST_ROOT=/opt/boost1.69 \
+ -DBoost_NO_SYSTEM_PATHS=TRUE
make
}