summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-13 19:48:21 +0100
committerGonçalo Camelo Neves Pereira2018-05-13 19:48:21 +0100
commit8aa3534cde242bb7f36a00e3f3a8648add848225 (patch)
tree0c93343226336c8d836c7d0b2f206c86f49f1fb7 /PKGBUILD
downloadaur-8aa3534cde242bb7f36a00e3f3a8648add848225.tar.gz
Update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD106
1 files changed, 106 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7781f4fc56de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,106 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Robot-independent Gazebo plugins for sensors, motors and dynamic reconfigurable components."
+url='http://gazebosim.org/tutorials?cat=connect_ros'
+
+pkgname='ros-melodic-gazebo-plugins'
+pkgver='2.8.2'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD, Apache 2.0')
+
+ros_makedepends=(ros-melodic-diagnostic-updater
+ ros-melodic-rosgraph-msgs
+ ros-melodic-std-srvs
+ ros-melodic-cv-bridge
+ ros-melodic-rosconsole
+ ros-melodic-tf
+ ros-melodic-std-msgs
+ ros-melodic-gazebo-msgs
+ ros-melodic-catkin
+ ros-melodic-gazebo-dev
+ ros-melodic-geometry-msgs
+ ros-melodic-dynamic-reconfigure
+ ros-melodic-trajectory-msgs
+ ros-melodic-nodelet
+ ros-melodic-tf2-ros
+ ros-melodic-urdf
+ ros-melodic-nav-msgs
+ ros-melodic-sensor-msgs
+ ros-melodic-camera-info-manager
+ ros-melodic-angles
+ ros-melodic-roscpp
+ ros-melodic-polled-camera
+ ros-melodic-image-transport
+ ros-melodic-message-generation
+ ros-melodic-rospy)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-diagnostic-updater
+ ros-melodic-rosgraph-msgs
+ ros-melodic-std-srvs
+ ros-melodic-cv-bridge
+ ros-melodic-rosconsole
+ ros-melodic-tf
+ ros-melodic-std-msgs
+ ros-melodic-gazebo-msgs
+ ros-melodic-geometry-msgs
+ ros-melodic-trajectory-msgs
+ ros-melodic-dynamic-reconfigure
+ ros-melodic-message-runtime
+ ros-melodic-nodelet
+ ros-melodic-tf2-ros
+ ros-melodic-urdf
+ ros-melodic-nav-msgs
+ ros-melodic-sensor-msgs
+ ros-melodic-camera-info-manager
+ ros-melodic-angles
+ ros-melodic-roscpp
+ ros-melodic-polled-camera
+ ros-melodic-image-transport
+ ros-melodic-gazebo-dev
+ ros-melodic-rospy)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/gazebo_plugins/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/gazebo_ros_pkgs-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="gazebo_ros_pkgs-release-release-melodic-gazebo_plugins-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/gazebo_ros_pkgs-release/archive/release/melodic/gazebo_plugins/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('faa163c8d6c1686dbf8fcacff3a775dd4229e0f0b266700caa65ab7f878a2093')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}