summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2020-02-16 08:21:34 -0500
committerGitHub2020-02-16 14:21:34 +0100
commit1e0d57aecc3c6b31c4487d91705543882e53b274 (patch)
treea90d7caa6925d8340303e908d399a43de0b6bc5f /PKGBUILD
parent67533eaaf24ee931067c9a56ed74ed08991c45ae (diff)
downloadaur-1e0d57aecc3c6b31c4487d91705543882e53b274.tar.gz
updpkg to 2.8.6 (#7)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD62
1 files changed, 29 insertions, 33 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 060f68cfd35d..cb9b08450344 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,55 +1,51 @@
# Script generated with import_catkin_packages.py
# For more information: https://github.com/bchretien/arch-ros-stacks
-pkgdesc="ROS - Provides ROS plugins that offer message and service publishers for interfacing with Gazebo through ROS."
-url='http://gazebosim.org/tutorials?cat=connect_ros'
+pkgdesc="ROS - Provides ROS plugins that offer message and service publishers
+for interfacing with Gazebo through ROS."
+url='http://wiki.ros.org/gazebo_ros'
pkgname='ros-melodic-gazebo-ros'
-pkgver='2.8.5'
+pkgver='2.8.6'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
-pkgrel=3
+pkgrel=1
license=('Apache 2.0')
-ros_makedepends=(ros-melodic-tf
- ros-melodic-std-msgs
- ros-melodic-gazebo-msgs
- ros-melodic-dynamic-reconfigure
- ros-melodic-roscpp
+ros_makedepends=(
ros-melodic-catkin
- ros-melodic-roslib
- ros-melodic-std-srvs
- ros-melodic-geometry-msgs
- ros-melodic-rosgraph-msgs
ros-melodic-cmake-modules
- ros-melodic-gazebo-dev)
-makedepends=('cmake' 'ros-build-tools'
+ ros-melodic-gazebo-dev
+ ros-melodic-gazebo-dev
+)
+
+makedepends=(
+ cmake
+ ros-build-tools
${ros_makedepends[@]}
- tinyxml)
+)
-ros_depends=(ros-melodic-tf
- ros-melodic-std-msgs
+ros_depends=(
+ ros-melodic-gazebo-dev
ros-melodic-gazebo-msgs
- ros-melodic-dynamic-reconfigure
- ros-melodic-roscpp
ros-melodic-roslib
+ ros-melodic-roscpp
+ ros-melodic-tf
ros-melodic-std-srvs
- ros-melodic-geometry-msgs
ros-melodic-rosgraph-msgs
- ros-melodic-gazebo-dev)
-depends=(${ros_depends[@]}
+ ros-melodic-dynamic-reconfigure
+ ros-melodic-std-msgs
+ ros-melodic-geometry-msgs
+)
+
+depends=(
+ ${ros_depends[@]}
tinyxml
- python)
+ python-argparse
+)
_dir="gazebo_ros_pkgs-${pkgver}/gazebo_ros"
-source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-simulation/gazebo_ros_pkgs/archive/${pkgver}.tar.gz"
- "spawn_model.patch")
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-simulation/gazebo_ros_pkgs/archive/${pkgver}.tar.gz")
-sha256sums=('0b0f6eeaeca611ebe12ec0ea4388121098fdafee5ecc8d76c6ae69b8b8f14aed'
- '8d561d1634519ad8a4bf937320f39e9c36248ec64862f766a7a16b010b0bfdb2')
-
-prepare() {
- cd "${srcdir}/${_dir}/scripts/"
- patch -uN spawn_model ../../../spawn_model.patch || return 1
-}
+sha256sums=('df928fbeebd277b8eedf7eb367ab88631de71ef6c552424731eaf855186bc4b4')
build() {
# Use ROS environment variables