summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorbionade242020-07-06 15:35:37 +0200
committerbionade242020-07-06 15:35:37 +0200
commit2629ee6fd55ca51bb3ecde81f94ccb97fc98842d (patch)
tree4a181a59c81c09e473f2348fcbbc5190716794a5 /PKGBUILD
parentf34401f013c35ebe9aa5e8845b6e6e47521e2155 (diff)
downloadaur-2629ee6fd55ca51bb3ecde81f94ccb97fc98842d.tar.gz
Set python version to 3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 46ff0c456f58..7cffa58bd624 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgname='ros-melodic-geometry2'
pkgver='0.6.5'
_pkgver_patch=0
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=(ros-melodic-catkin)
@@ -47,14 +47,14 @@ build() {
cd ${srcdir}/build
# Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
# Build project
cmake ${srcdir}/${_dir} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
-DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
-DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-DPYTHON_BASENAME=-python2.7 \