summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTimon Engelke2018-09-07 00:35:36 +0200
committerTimon Engelke2018-09-07 00:35:36 +0200
commita745cf5e0af8c198f3117635ee7fb1d7a3725431 (patch)
tree1fd85d8cb356c16775573f27fc667044d04bb74a /PKGBUILD
downloadaur-a745cf5e0af8c198f3117635ee7fb1d7a3725431.tar.gz
Initial
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD75
1 files changed, 75 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4866dde3320
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,75 @@
+# Maintainer: Timon Engelke <aur@timonengelke.de>
+pkgdesc="ROS - Messages, services and actions used by MoveIt."
+url='http://moveit.ros.org'
+
+pkgname='ros-melodic-moveit-msgs'
+pkgver='0.10.0'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-actionlib-msgs
+ ros-melodic-trajectory-msgs
+ ros-melodic-message-generation
+ ros-melodic-octomap-msgs
+ ros-melodic-object-recognition-msgs
+ ros-melodic-geometry-msgs
+ ros-melodic-std-msgs
+ ros-melodic-sensor-msgs
+ ros-melodic-catkin
+ ros-melodic-shape-msgs)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-actionlib-msgs
+ ros-melodic-trajectory-msgs
+ ros-melodic-octomap-msgs
+ ros-melodic-object-recognition-msgs
+ ros-melodic-geometry-msgs
+ ros-melodic-message-runtime
+ ros-melodic-std-msgs
+ ros-melodic-sensor-msgs
+ ros-melodic-shape-msgs)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/moveit_msgs/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/moveit_msgs-release.git"#tag=${_tag})
+# sha256sums=('cf24076ec34f836693b7818e7a36097b50581a66f98518666ebe3f7ba5ef2376')
+
+# Tarball version (faster download)
+_dir="moveit_msgs-release-release-melodic-moveit_msgs-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/moveit_msgs-release/archive/release/melodic/moveit_msgs/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('d1053ffe57d739fff282835af4753e39f484acad8a596049f8dc97825abeb881')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=-python3.7m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}