summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelix Exner2020-08-26 03:57:37 +0200
committerFelix Exner2020-08-26 03:57:37 +0200
commitce1c36b9dcbcc4f0ce6082f5ecef920c95528ed8 (patch)
treea8fa3601923a0fd29abfbdf31fd47e6ddbd9aed7 /PKGBUILD
downloadaur-ce1c36b9dcbcc4f0ce6082f5ecef920c95528ed8.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD61
1 files changed, 61 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aea70d2c19ce
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,61 @@
+# Script generated with create_pkgbuild.py
+# For more information: https://github.com/ros-melodic-arch/ros-build-tools-py3
+pkgdesc="ROS - PR2 Resources used for MoveIt! testing."
+url='h'
+
+pkgname='ros-melodic-moveit-resources-pr2-description'
+pkgver='0.7.0'
+arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(
+ ros-melodic-catkin
+)
+
+makedepends=(
+ 'cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
+
+ros_depends=(
+)
+
+depends=(
+ ${ros_depends[@]}
+)
+
+_dir="moveit_resources-release-release-melodic-moveit_resources_pr2_description"
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/ros-gbp/moveit_resources-release/archive/release/melodic/moveit_resources_pr2_description/${pkgver}.tar.gz")
+sha256sums=('0ccf03e91f75d1f48c1b50dfba09cde3f08a32a6cb348773cb904ee033a0c901')
+
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.8 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.8.so \
+ -DPYTHON_BASENAME=.cpython-38 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}