summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelix Exner2021-01-20 14:42:34 +0100
committerFelix Exner2021-01-20 14:42:34 +0100
commitdf8dfe2589719a79be99d942de0c0be63205c79d (patch)
tree08e8524089bafd2941c7976a98ad8b6eaac5f05b /PKGBUILD
parent8efc50d0d6a40f58126f4a6c4c02e10c6c656b96 (diff)
downloadaur-df8dfe2589719a79be99d942de0c0be63205c79d.tar.gz
Setup boost path during build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c70653fac9d0..9ffe8cb6d434 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ url='https://moveit.ros.org'
pkgname='ros-melodic-moveit-ros-perception'
pkgver='1.0.7'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=(ros-melodic-message-filters
@@ -89,7 +89,9 @@ build() {
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DBOOST_ROOT=/opt/boost1.69 \
+ -DBoost_NO_SYSTEM_PATHS=TRUE
make
}