summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoracxz2019-11-25 19:50:44 -0500
committerGitHub2019-11-25 19:50:44 -0500
commit5789f0ce8f4d8fd3794c4b6d6ad10904e1a7a729 (patch)
tree8eee44551c409427d7d64f409606041b18c74614 /PKGBUILD
parent5d22ec9041a9a6e0c72a733b3dc1146d07f74d61 (diff)
parentea6b51fb966ca3ff0f180681b7615b13492b85df (diff)
downloadaur-5789f0ce8f4d8fd3794c4b6d6ad10904e1a7a729.tar.gz
Merge pull request #2 from jwhendy/master
ros-melodic-moveit-resources is now a test depend; update to python3.8
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 721f2f3ff98c..4fd5356c6e18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ url='https://moveit.ros.org'
pkgname='ros-melodic-moveit-ros-planning-interface'
pkgver='1.0.2'
arch=('any')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=(ros-melodic-tf-conversions
@@ -19,6 +19,7 @@ ros_makedepends=(ros-melodic-tf-conversions
ros-melodic-eigen-conversions
ros-melodic-moveit-ros-manipulation
ros-melodic-rosconsole
+ ros-melodic-moveit-resources
ros-melodic-catkin)
makedepends=('cmake' 'ros-build-tools'
${ros_makedepends[@]}
@@ -85,9 +86,9 @@ build() {
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=-python3.7m \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.8 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.8.so \
+ -DPYTHON_BASENAME=.cpython-38 \
-DSETUPTOOLS_DEB_LAYOUT=OFF
make
}