summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorFelix Exner2021-01-20 14:48:50 +0100
committerFelix Exner2021-01-20 14:48:50 +0100
commitcae8d3a7a02321bbc6e3fab8af98f234e2965908 (patch)
tree01e001b13d3334559695bb8735e067c48b634e81 /PKGBUILD
parentb4fb668cec621fb252a0a87511aeabf4f4a276cf (diff)
downloadaur-cae8d3a7a02321bbc6e3fab8af98f234e2965908.tar.gz
Setup boost path during build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 794efc3729af..1b7f46b31d86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ url='https://moveit.ros.org'
pkgname='ros-melodic-moveit-ros-warehouse'
pkgver='1.0.7'
arch=('i686' 'x86_64' 'aarch64' 'armv7h' 'armv6h')
-pkgrel=1
+pkgrel=2
license=('BSD')
ros_makedepends=(ros-melodic-tf
@@ -53,7 +53,9 @@ build() {
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
-DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
+ -DSETUPTOOLS_DEB_LAYOUT=OFF \
+ -DBOOST_ROOT=/opt/boost1.69 \
+ -DBoost_NO_SYSTEM_PATHS=TRUE
make
}