summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-09-26 13:28:43 +0200
committerGonçalo Camelo Neves Pereira2018-09-26 13:28:43 +0200
commit0fbf3c0917583710f88db3ed42f0dd42b9c942b8 (patch)
tree6e8ad689bf9a1e1c7991c0240591324753d26ddd /PKGBUILD
parentd434136a3a36d484e8818aa40e6e8bc42a34d5fc (diff)
downloadaur-0fbf3c0917583710f88db3ed42f0dd42b9c942b8.tar.gz
Update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD123
1 files changed, 54 insertions, 69 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 61436f04f639..0d15a579fa3f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py.
-# For more information: https://github.com/bchretien/arch-ros-stacks.
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
pkgdesc="ROS - The nodelet package is designed to provide a way to run multiple algorithms in the same process with zero copy transport between algorithms."
url='http://ros.org/wiki/nodelet'
@@ -10,82 +10,67 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(
- ros-melodic-pluginlib
- ros-melodic-message-generation
- ros-melodic-catkin
- ros-melodic-cmake-modules
- ros-melodic-bondcpp
- ros-melodic-rosconsole
- ros-melodic-roscpp
- ros-melodic-std-msgs
-)
+ros_makedepends=(ros-melodic-rosconsole
+ ros-melodic-std-msgs
+ ros-melodic-roscpp
+ ros-melodic-catkin
+ ros-melodic-pluginlib
+ ros-melodic-message-generation
+ ros-melodic-bondcpp
+ ros-melodic-cmake-modules)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]}
+ util-linux
+ boost)
-makedepends=(
- 'cmake'
- 'ros-build-tools'
- ${ros_makedepends[@]}
- boost
- util-linux
-)
+ros_depends=(ros-melodic-rosconsole
+ ros-melodic-std-msgs
+ ros-melodic-message-runtime
+ ros-melodic-roscpp
+ ros-melodic-pluginlib
+ ros-melodic-bondcpp
+ ros-melodic-rospy)
+depends=(${ros_depends[@]}
+ util-linux
+ boost)
-ros_depends=(
- ros-melodic-message-runtime
- ros-melodic-pluginlib
- ros-melodic-rospy
- ros-melodic-bondcpp
- ros-melodic-rosconsole
- ros-melodic-roscpp
- ros-melodic-std-msgs
-)
+# Git version (e.g. for debugging)
+# _tag=release/melodic/nodelet/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/ros-gbp/nodelet_core-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
-depends=(
- ${ros_depends[@]}
- boost
- util-linux
-)
-
-_dir=${pkgname}
-source=("${_dir}"::"git+https://github.com/ros-gbp/nodelet_core-release.git")
-sha256sums=('SKIP')
-
-prepare() {
- cd ${srcdir}/${_dir}
- git checkout upstream
- _pkgname=$(echo ${pkgname} | sed 's/ros-lunar-//' | sed 's/-/_/g')
-
- if [ -d ${_pkgname} ]; then
- git subtree split -P ${_pkgname} --branch ${_pkgname}
- git checkout ${_pkgname}
- fi
-}
+# Tarball version (faster download)
+_dir="nodelet_core-release-release-melodic-nodelet-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/nodelet_core-release/archive/release/melodic/nodelet/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('3a9e9701df570659d70f871eb7e1970dacd3b89c02513c456f8f0ea1a446d15a')
build() {
- # Use ROS environment variables.
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create the build directory.
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts.
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build the project.
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}