summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2019-01-09 19:17:03 +0100
committerGonçalo Camelo Neves Pereira2019-01-09 19:17:03 +0100
commit71666948d27157f3666aa374d3464c833943e770 (patch)
tree7a4ada357f7e837fab1d4751d7455dcc6e9b7fb8 /PKGBUILD
parent0fbf3c0917583710f88db3ed42f0dd42b9c942b8 (diff)
downloadaur-71666948d27157f3666aa374d3464c833943e770.tar.gz
New Version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD106
1 files changed, 55 insertions, 51 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0d15a579fa3f..2d7420996f59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - The nodelet package is designed to provide a way to run multiple algorithms in the same process with zero copy transport between algorithms."
url='http://ros.org/wiki/nodelet'
@@ -10,67 +10,71 @@ arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-rosconsole
- ros-melodic-std-msgs
- ros-melodic-roscpp
- ros-melodic-catkin
- ros-melodic-pluginlib
- ros-melodic-message-generation
- ros-melodic-bondcpp
- ros-melodic-cmake-modules)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]}
- util-linux
- boost)
+ros_makedepends=(
+ ros-melodic-bondcpp
+ ros-melodic-cmake-modules
+ ros-melodic-catkin
+ ros-melodic-message-generation
+ ros-melodic-std-msgs
+ ros-melodic-rosconsole
+ ros-melodic-roscpp
+ ros-melodic-pluginlib
+)
-ros_depends=(ros-melodic-rosconsole
- ros-melodic-std-msgs
- ros-melodic-message-runtime
- ros-melodic-roscpp
- ros-melodic-pluginlib
- ros-melodic-bondcpp
- ros-melodic-rospy)
-depends=(${ros_depends[@]}
- util-linux
- boost)
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+ boost
+ util-linux
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/nodelet/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/nodelet_core-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-bondcpp
+ ros-melodic-std-msgs
+ ros-melodic-rosconsole
+ ros-melodic-roscpp
+ ros-melodic-message-runtime
+ ros-melodic-rospy
+ ros-melodic-pluginlib
+)
+
+depends=(
+ ${ros_depends[@]}
+ boost
+ util-linux
+)
-# Tarball version (faster download)
_dir="nodelet_core-release-release-melodic-nodelet-${pkgver}-${_pkgver_patch}"
source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/nodelet_core-release/archive/release/melodic/nodelet/${pkgver}-${_pkgver_patch}.tar.gz")
sha256sums=('3a9e9701df570659d70f871eb7e1970dacd3b89c02513c456f8f0ea1a446d15a')
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}