summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2018-05-08 15:09:42 +0100
committerGonçalo Camelo Neves Pereira2018-05-08 15:09:42 +0100
commitf27a75cb6849cfb4960feef5a14aeac98e3df062 (patch)
treeab4f8881dcfbafcb2b6dbd8ffdfcaeca459eccc4 /PKGBUILD
downloadaur-f27a75cb6849cfb4960feef5a14aeac98e3df062.tar.gz
Update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD66
1 files changed, 66 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..05946348ffec
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,66 @@
+# Script generated with import_catkin_packages.py
+# For more information: https://github.com/bchretien/arch-ros-stacks
+pkgdesc="ROS - Launch a PID control node."
+url='http://wiki.ros.org/pid'
+
+pkgname='ros-melodic-pid'
+pkgver='0.0.24'
+_pkgver_patch=0
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-catkin
+ ros-melodic-message-generation
+ ros-melodic-roscpp
+ ros-melodic-dynamic-reconfigure
+ ros-melodic-std-msgs)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-message-runtime
+ ros-melodic-roscpp
+ ros-melodic-dynamic-reconfigure
+ ros-melodic-std-msgs)
+depends=(${ros_depends[@]})
+
+# Git version (e.g. for debugging)
+# _tag=release/melodic/pid/${pkgver}-${_pkgver_patch}
+# _dir=${pkgname}
+# source=("${_dir}"::"git+https://github.com/AndyZe/pid-release.git"#tag=${_tag})
+# sha256sums=('SKIP')
+
+# Tarball version (faster download)
+_dir="pid-release-release-melodic-pid-${pkgver}-${_pkgver_patch}"
+source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/AndyZe/pid-release/archive/release/melodic/pid/${pkgver}-${_pkgver_patch}.tar.gz")
+sha256sums=('4baac5e9ab0d98621a2820dcb7b76af518507666b7fc23ba7e117a8194366894')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python2 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
+ -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
+ -DPYTHON_BASENAME=-python2.7 \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
+}