summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2019-01-09 19:22:46 +0100
committerGonçalo Camelo Neves Pereira2019-01-09 19:22:46 +0100
commit84d82bc8b3d3e91de82dd1889fb0f6b04e9fd417 (patch)
tree6d562d947a507e20a9450f2f945347ce02eed82d /PKGBUILD
parent08827d00af19a20668c71df0c43bde7fe78d05db (diff)
downloadaur-84d82bc8b3d3e91de82dd1889fb0f6b04e9fd417.tar.gz
New Version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD86
1 files changed, 45 insertions, 41 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d09e4a11166d..48ec53c7f116 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,64 +1,68 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - This package defines messages for commonly used sensors, including cameras and scanning laser rangefinders."
url='http://ros.org/wiki/sensor_msgs'
pkgname='ros-melodic-sensor-msgs'
-pkgver='1.12.6'
+pkgver='1.12.7'
_pkgver_patch=0
arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-catkin
- ros-melodic-message-generation
- ros-melodic-geometry-msgs
- ros-melodic-std-msgs)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]})
+ros_makedepends=(
+ ros-melodic-message-generation
+ ros-melodic-std-msgs
+ ros-melodic-catkin
+ ros-melodic-geometry-msgs
+)
-ros_depends=(ros-melodic-message-runtime
- ros-melodic-geometry-msgs
- ros-melodic-std-msgs)
-depends=(${ros_depends[@]})
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/sensor_msgs/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/common_msgs-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-message-runtime
+ ros-melodic-std-msgs
+ ros-melodic-geometry-msgs
+)
+
+depends=(
+ ${ros_depends[@]}
+)
-# Tarball version (faster download)
_dir="common_msgs-release-release-melodic-sensor_msgs-${pkgver}-${_pkgver_patch}"
source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/common_msgs-release/archive/release/melodic/sensor_msgs/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('9b8f1e3a1682164fece7f32c145a48aeb66d0f3b56ccd4755b462be2773e94d1')
+sha256sums=('25b8448825591eb461e1d3e24c32fd2a1f2e1e2e69c56bd67748c54c7f8d3529')
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}