summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorZHOU Yue2018-09-27 17:33:21 +0800
committerZHOU Yue2018-09-27 17:33:21 +0800
commit23625cfcb50d4fab428d6f75bc0f3affe6cde1fc (patch)
tree9f83595477f2970745b461b2ffd55306d3408b1d /PKGBUILD
parente01efdd944b5121f152155cb2bd107857bcce934 (diff)
downloadaur-23625cfcb50d4fab428d6f75bc0f3affe6cde1fc.tar.gz
change to use python3.7
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 10 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ca1afd32a5f2..00acb6c23f89 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ pkgdesc='Generic CAN interface description with helpers for filtering and driver
url="http://wiki.ros.org/${_pkgname}?distro=melodic"
pkgver=0.8.0
-pkgrel=1
+pkgrel=2
arch=('any')
license=('LGPL3')
@@ -30,23 +30,23 @@ build() {
source /usr/share/ros-build-tools/clear-ros-env.sh
[ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
-# # Fix Python2/Python3 conflicts
-# /usr/share/ros-build-tools/fix-python-scripts.sh -v 2 ${srcdir}/${_dir}
-
# Create build directory
- [ -d ${srcdir}/build ] || mkdir -p ${srcdir}/build
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
cd ${srcdir}/build
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
# Build project
cmake ${srcdir}/${_dir}/${_pkgname} \
-DCMAKE_BUILD_TYPE=Release \
-DCATKIN_BUILD_BINARY_PACKAGE=ON \
-DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python2 \
-# -DPYTHON_INCLUDE_DIR=/usr/include/python2.7 \
-# -DPYTHON_LIBRARY=/usr/lib/libpython2.7.so \
-# -DPYTHON_BASENAME=-python2.7 \
-# -DSETUPTOOLS_DEB_LAYOUT=OFF
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
make
}