summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authormajor major2020-03-12 15:35:06 +0100
committermajor major2020-03-12 15:35:06 +0100
commita8bd7910126aea821325fe1dbc74c4ff5f3ddd41 (patch)
tree66b19442bac5aa1b9fb8ffcf17aebfc129044eed /PKGBUILD
downloadaur-a8bd7910126aea821325fe1dbc74c4ff5f3ddd41.tar.gz
first commit of ros-melodic-swri-math-util
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD52
1 files changed, 52 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f42c33207b34
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Script generated with create_pkgbuild.py
+# For more information: https://github.com/ros-melodic-arch/ros-build-tools-py3
+pkgdesc="ROS - swri_math_util."
+url='https://github.com/swri-robotics/marti_common'
+
+pkgname='ros-melodic-swri-math-util'
+pkgver='2.11.0'
+arch=('any')
+pkgrel=1
+license=('BSD')
+
+ros_makedepends=(ros-melodic-catkin
+ ros-melodic-roscpp)
+makedepends=('cmake' 'ros-build-tools'
+ ${ros_makedepends[@]})
+
+ros_depends=(ros-melodic-roscpp)
+depends=(${ros_depends[@]})
+
+_dir=marti_common-release-release-melodic-swri_math_util
+source=("${pkgname}-${pkgver}.tar.gz"::"https://github.com/swri-robotics-gbp/marti_common-release/archive/release/melodic/swri_math_util/${pkgver}.tar.gz")
+sha256sums=('e4be3db0df752a6aa949bbe8ed2ea43fcdd64a34013efd9eaf3709be291de456')
+
+build() {
+ # Use ROS environment variables
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+
+ # Create build directory
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
+
+ # Fix Python2/Python3 conflicts
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+
+ # Build project
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.8m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.8m.so \
+ -DPYTHON_BASENAME=.cpython-38m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
+}
+
+package() {
+cd "${srcdir}/build"
+make DESTDIR="${pkgdir}/" install
+}