summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonçalo Camelo Neves Pereira2019-01-09 19:16:34 +0100
committerGonçalo Camelo Neves Pereira2019-01-09 19:16:34 +0100
commit83000be82653cb92562a394ee1e46c570a98181c (patch)
tree3f1c0c3df030d6905c73ef2826505455bebc8620 /PKGBUILD
parentb05c6c4997cb716151576c7ea8baf82a5e58fedf (diff)
downloadaur-83000be82653cb92562a394ee1e46c570a98181c.tar.gz
New Version
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD90
1 files changed, 47 insertions, 43 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d56e9f4e93d7..0df672d4b40c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,66 +1,70 @@
-# Script generated with import_catkin_packages.py
-# For more information: https://github.com/bchretien/arch-ros-stacks
+# Script generated with import_catkin_packages.py.
+# For more information: https://github.com/bchretien/arch-ros-stacks.
pkgdesc="ROS - tf2 is the second generation of the transform library, which lets the user keep track of multiple coordinate frames over time."
url='http://www.ros.org/wiki/tf2'
pkgname='ros-melodic-tf2'
-pkgver='0.6.3'
+pkgver='0.6.5'
_pkgver_patch=0
arch=('any')
pkgrel=1
license=('BSD')
-ros_makedepends=(ros-melodic-catkin
- ros-melodic-tf2-msgs
- ros-melodic-geometry-msgs
- ros-melodic-rostime)
-makedepends=('cmake' 'ros-build-tools'
- ${ros_makedepends[@]}
- console-bridge)
+ros_makedepends=(
+ ros-melodic-rostime
+ ros-melodic-tf2-msgs
+ ros-melodic-catkin
+ ros-melodic-geometry-msgs
+)
-ros_depends=(ros-melodic-tf2-msgs
- ros-melodic-geometry-msgs
- ros-melodic-rostime)
-depends=(${ros_depends[@]}
- console-bridge)
+makedepends=(
+ 'cmake'
+ 'ros-build-tools'
+ ${ros_makedepends[@]}
+ console-bridge
+)
-# Git version (e.g. for debugging)
-# _tag=release/melodic/tf2/${pkgver}-${_pkgver_patch}
-# _dir=${pkgname}
-# source=("${_dir}"::"git+https://github.com/ros-gbp/geometry2-release.git"#tag=${_tag})
-# sha256sums=('SKIP')
+ros_depends=(
+ ros-melodic-rostime
+ ros-melodic-tf2-msgs
+ ros-melodic-geometry-msgs
+)
+
+depends=(
+ ${ros_depends[@]}
+ console-bridge
+)
-# Tarball version (faster download)
_dir="geometry2-release-release-melodic-tf2-${pkgver}-${_pkgver_patch}"
source=("${pkgname}-${pkgver}-${_pkgver_patch}.tar.gz"::"https://github.com/ros-gbp/geometry2-release/archive/release/melodic/tf2/${pkgver}-${_pkgver_patch}.tar.gz")
-sha256sums=('6e27c4842b75f4a0855ce5768b5b8a0ee3a1f26f061b21c38de83d6e6916b9c1')
+sha256sums=('f6776b600f397998cef387bfa57b6ad3e1e396f7a0015521ba7389ce2ca211c4')
build() {
- # Use ROS environment variables
- source /usr/share/ros-build-tools/clear-ros-env.sh
- [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
+ # Use ROS environment variables.
+ source /usr/share/ros-build-tools/clear-ros-env.sh
+ [ -f /opt/ros/melodic/setup.bash ] && source /opt/ros/melodic/setup.bash
- # Create build directory
- [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
- cd ${srcdir}/build
+ # Create the build directory.
+ [ -d ${srcdir}/build ] || mkdir ${srcdir}/build
+ cd ${srcdir}/build
- # Fix Python2/Python3 conflicts
- /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
+ # Fix Python2/Python3 conflicts.
+ /usr/share/ros-build-tools/fix-python-scripts.sh -v 3 ${srcdir}/${_dir}
- # Build project
- cmake ${srcdir}/${_dir} \
- -DCMAKE_BUILD_TYPE=Release \
- -DCATKIN_BUILD_BINARY_PACKAGE=ON \
- -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
- -DPYTHON_EXECUTABLE=/usr/bin/python3 \
- -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
- -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
- -DPYTHON_BASENAME=.cpython-37m \
- -DSETUPTOOLS_DEB_LAYOUT=OFF
- make
+ # Build the project.
+ cmake ${srcdir}/${_dir} \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCATKIN_BUILD_BINARY_PACKAGE=ON \
+ -DCMAKE_INSTALL_PREFIX=/opt/ros/melodic \
+ -DPYTHON_EXECUTABLE=/usr/bin/python3 \
+ -DPYTHON_INCLUDE_DIR=/usr/include/python3.7m \
+ -DPYTHON_LIBRARY=/usr/lib/libpython3.7m.so \
+ -DPYTHON_BASENAME=.cpython-37m \
+ -DSETUPTOOLS_DEB_LAYOUT=OFF
+ make
}
package() {
- cd "${srcdir}/build"
- make DESTDIR="${pkgdir}/" install
+ cd "${srcdir}/build"
+ make DESTDIR="${pkgdir}/" install
}